Home
Scripts
Contributions (Pro Mod Access)
FAQ's
Downloads
Support Forum
  SnailSource.com [Logo]
Calendar LiteCalendar Lite (Demo)
Calendar ProCalendar Pro (Demo)
LinksLinks Pro (Demo)
Log in to check your private messagesForum
RegisterRegister
Log inLog in
Log in to check your private messagesLog in to check your private messages SearchSearch FAQFAQ ProfileProfile MemberlistMemberlist UsergroupsUsergroups Join GroupsJoin Groups

very strange problem with calender 1.2.2m

 
Post new topic   Reply to topic   printer-friendly view    SnailSource.com Forum Index -> Calendar Lite Support printer-friendly view
View previous topic :: View next topic  
Author Message
Chillem



Joined: 04 Sep 2002
Posts: 6



Hlp* 0.10
PostPosted: Sat Oct 05, 2002 11:12 pm    Post subject: very strange problem with calender 1.2.2m Reply with quote Direct link

hi

i had just instald calender 1.2.2m an do everything just right I think. i read it all over and over again but i can't find the problem.

the problem is that i can view calender link whitout logged in. but when i log in the calender link is gone.



this is how my cal_settings.php settings are.
Code:

$tablename = 'calendar';

$allowanonview = 'no';

$usersuggest = 'yes';   

$allowreguser = 'yes';

$allowold = 'yes';

$showheaders = 'yes';

$subjectlen = 13;

$dateoverride = 'D d M, Y H:i';


my fonctions.php are

Code:

if ( defined('IN_ADMIN') )
   {
      if( !file_exists($phpbb_root_path . 'language/lang_' . $board_config['default_lang'] . '/lang_admin.'.$phpEx) )
      {
         $board_config['default_lang'] = 'english';
      }

      include($phpbb_root_path . 'language/lang_' . $board_config['default_lang'] . '/lang_admin.' . $phpEx);
   }

   if ( !file_exists($phpbb_root_path . 'language/lang_' . $board_config['default_lang'] . '/lang_calendar.'.$phpEx) )
   {
      $board_config['default_lang'] = 'english';
   }

   include($phpbb_root_path . 'language/lang_' . $board_config['default_lang'] . '/lang_calendar.' . $phpEx);


   //
   // Set up style


my overall_header.tpl is:
Code:

<!-- BEGIN switch_user_logged_out -->
                  &nbsp;<a href="{U_REGISTER}" class="mainmenu">
<img src="templates/subSilver/images/icon_mini_register.gif" width="12" height="13" border="0" alt="{L_REGISTER}" hspace="3" />
{L_REGISTER}</a></span>&nbsp;

&nbsp;<a href="{U_CALENDAR_MOD}" class="mainmenu">
<img src="templates/subSilver/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_CALENDAR_MOD}" hspace="3" />{L_CALENDAR_MOD}</a>&nbsp;
                  <!-- END switch_user_logged_out -->


That's all what's maybe going wrong...
Back to top
View user's profile Send private message
Martin
Site Admin


Joined: 24 Mar 2002
Posts: 8182



Hlp* 3655.72
PostPosted: Sun Oct 06, 2002 12:14 pm    Post subject: Re: very strange problem with calender 1.2.2m Reply with quote Direct link

Chillem wrote:
hi

i had just instald calender 1.2.2m an do everything just right I think. i read it all over and over again but i can't find the problem.

the problem is that i can view calender link whitout logged in. but when i log in the calender link is gone.my overall_header.tpl is:

Quote:

<!-- BEGIN switch_user_logged_out -->
&nbsp;<a href="{U_REGISTER}" class="mainmenu">
<img src="templates/subSilver/images/icon_mini_register.gif" width="12" height="13" border="0" alt="{L_REGISTER}" hspace="3" />
{L_REGISTER}</a></span>&nbsp;
<!-- END switch_user_logged_out -->
&nbsp;<a href="{U_CALENDAR_MOD}" class="mainmenu">
<img src="templates/subSilver/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_CALENDAR_MOD}" hspace="3" />{L_CALENDAR_MOD}</a>&nbsp;
<!-- END switch_user_logged_out -->


That's all what's maybe going wrong...


That's your problem... Move the Red code to where it's shown in Green
Wink
Back to top
View user's profile Send private message
Chillem



Joined: 04 Sep 2002
Posts: 6



Hlp* 0.10
PostPosted: Sun Oct 06, 2002 4:54 pm    Post subject: not the problem! Reply with quote Direct link

hi,

i have tried that, but it's not the problem..

now i see it even not when i logged out...


i had no problem whit calendar version K
it's only with version M.
Back to top
View user's profile Send private message
Chillem



Joined: 04 Sep 2002
Posts: 6



Hlp* 0.10
PostPosted: Sun Oct 06, 2002 5:01 pm    Post subject: allright.... Reply with quote Direct link

allright i have worked out the problem...

the code must be above, instead under the <!-- BEGIN switch_user_logged_out -->

the code is now:
Code:

&nbsp;<a href="{U_GROUP_CP}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_USERGROUPS}" hspace="3" />{L_USERGROUPS}</a>&nbsp; [color=red]&nbsp;<a href="{U_CALENDAR_MOD}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_CALENDAR_MOD}" hspace="3" />{L_CALENDAR_MOD}</a>&nbsp;[/color]   
      
<!-- BEGIN switch_user_logged_out -->
                  &nbsp;<a href="{U_REGISTER}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_register.gif" width="12" height="13" border="0" alt="{L_REGISTER}" hspace="3" />{L_REGISTER}</a></span>&nbsp;

<!-- END switch_user_logged_out -->


tnx for you reaction..
Back to top
View user's profile Send private message
Martin
Site Admin


Joined: 24 Mar 2002
Posts: 8182



Hlp* 3655.72
PostPosted: Sun Oct 06, 2002 6:15 pm    Post subject: Re: allright.... Reply with quote Direct link

Chillem wrote:
allright i have worked out the problem...

The problem was that you had your Calendar link between.
Code:
<!-- BEGIN switch_user_logged_out -->

... and ...
Code:
<!-- END switch_user_logged_out -->

This is only shown if the user is not logged in... So if you logged in, not only did the "Register" link disappear but also the "Calendar" link... Which is what I explained above...

So to anyone else who has this problem... Make sure you don't put the Calendar link between those 2 specific template markers.
Back to top
View user's profile Send private message
Chillem



Joined: 04 Sep 2002
Posts: 6



Hlp* 0.10
PostPosted: Sun Oct 06, 2002 6:29 pm    Post subject: tnx.... Reply with quote Direct link

thank you!!!

you was very helpfull.

greetzz Chillem
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic   printer-friendly view    SnailSource.com Forum Index -> Calendar Lite Support All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

This board is protected by Phpbbantispam
Board Security

15564 Attacks blocked

Powered by phpBB © 2001, 2005 phpBB Group